Ben Langhinrichs

Photograph of Ben Langhinrichs

E-mail address - Ben Langhinrichs







Recent posts

Wed 18 Sep 2019

Perils of PDF 5: Data Confusion



Mon 16 Sep 2019

About that email in Notes



Mon 9 Sep 2019

Perils of PDF 4: Missing and obscured data


November, 2019
SMTWTFS
     01 02
03 04 05 06 07 08 09
10 11 12 13 14 15 16
17 18 19 20 21 22 23
24 25 26 27 28 29 30

Search the weblog





























Genii Weblog

Upgrading to Midas 3.x - Why?

Tue 25 May 2004, 12:50 PM



by Ben Langhinrichs
It is hard to switch perspective sometimes and see the world from a customer's point of view.  While it is easy for me to understand why not to upgrade my Windows OS version, or why not to upgrade my Notes version, it is harder to understand why people would not want to upgrade their Midas version.  It seems so obvious to me, and not just because my daughter is going to college next year <grin>.  But then, I am reminded that other people have to pay to upgrade, and they have to justify the cost, not just of the relatively reasonable upgrade fee, but also of testing and of taking a risk that something will have changed.

So, for those perfectly reasonable people who may wonder "Why bother?", I'll try to pull together a few reasons.  Whether these are compelling or not may depend on your perspective.  No matter what your perspective is though, the upgrade discount of 50% only applies through the end of May, so if it is compelling, better jump while the jumping is good.

Reasons to Upgrade from Midas 2.x to 3.x:

Separate, and above all else for many people:
  • Midas 2.x is not supported for Notes/Domino 6.x or 6.5x.  Midas 3.x supports all Notes releases from 4.5x to 6.5x.  Using 2.x versions may work with ND 6.x and above, but is likely to cause data corruptions and odd results, and the frequency of such problems is likely to increase with time.


Other good reasons (not all-inclusive, but a good start):
  • Support for layers and other Notes 6 rich text constructs
  • Support for Notes 6 parameters on older constructs (e.g., support for captioned tables)
  • Support for creating and modifying image maps
  • SmartRefs technology allowing dynamic cross referencing and much more (see this news article)
  • Extensive changes and improvements to HTML generation capabilities
  • HTML import to allow conversion of HTML with CSS and such to high quality rich text
  • Ability to convert Notes Bitmap images to GIF images, and better handling of graphics in general (6.0.2 and above)
  • Performance enhancements on finding and modifying text chunks
  • Better handling of HTML attributes on tables, fields and other constructs
  • Workaround techniques for Notes version related issues (such as this one)
  • Exporting to MIME files
  • Advanced sorting for tables, including secondary columns, accent and case sensitive sorting, etc.
  • Better handling of international characters.


One last reason:
  • Support for Midas 2.x is dying, going away, less and less helpful, etc.  Face it, almost eighteen months after the last maintenance release, your problems are just more likely to get solved if you use Midas 3.x, and all upgrades within 3.x are free if you upgrade to any 3.x version.  In fact, due to our constant effort to tune and improve, you are less likely to have problems if you upgrade.


So, compelling or not, those are some reasons.  Of course, if you want to continue using 2.x, or even 1.x for that matter, you certainly can.  You have a perpetual license, and if you are not upgrading to Notes 6 and beyond,  and if your applications still work, why not keep using it.  I still use Windows 98, so who am I to complain?

Copyright © 2004 Genii Software Ltd.

What has been said:

No documents found