Ben Langhinrichs

Photograph of Ben Langhinrichs

E-mail address - Ben Langhinrichs






February, 2008
SMTWTFS
     01 02
03 04 05 06 07 08 09
10 11 12 13 14 15 16
17 18 19 20 21 22 23
24 25 26 27 28 29

Search the weblog





























Genii Weblog


Civility in critiquing the ideas of others is no vice. Rudeness in defending your own ideas is no virtue.


Fri 22 Feb 2008, 01:49 PM
For many years, I have made sure to use the same Notes client version as most of my customers, and just switch to other client versions for various tests and support issues, etc.  This always makes it difficult to know when exactly to switch.  To make this a bit easier, I usually use something different on my laptop than on my main development machine.  So, currently, I am using Notes 6.5.3 for most regular e-mail work and checking forums and that sort of daily task.  I have Notes 7.0.2 on my laptop for the same sort of purpose.  Obviously, both machines have multiple other versions as well, but those are the ones I use for regular tasks.

The problem is I have Notes 8.0.1 envy.  I can't possibly argue that the majority, or even a significant minority, of my users are on 8.0.1, although a significant minority are at least somehow using 8.0.0.  But I don't want to wait.  I want widgets.  I want Symphony.  I want LiveText.  I want them now.

What is a responsible developer to do?  I guess I could switch on my laptop, but I don't use it quite often enough.  I think when I come back from Germany, I'll switch my main desktop, and the heck with my customers.  If they aren't all scrambling to get 8.0.1 by now, I don't know what's wrong with them anyway.

Copyright 2008 Genii Software Ltd.

Tags: